Resolved
Networking has been restored and instances are coming back online
Investigating
An upstream provider was performing a planned networking upgrade that failed. Based on the information available, their engineers are on-site and actively investigating.
The issue appears to affect public internet connectivity specifically; underlying servers remain running. We are actively diverting new workloads away from the affected data center and will provide updates as we receive more information.
Billing for affected instances has been paused.